Q-Sims - Troubleshooting

From QNAPedia
Revision as of 16:49, 27 October 2015 by Glenn (talk | contribs) (catchg)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
by AdNovea - May 2009
Q-Sims Homepage

Error during (re)installation with the Q-Sims FULL Edition

  • If you have entered wrong data or crash during the QSA you may end with a blank page. Go into the QSims/web/qsmanager/settings folder and delete the config.php file. The installation (QSA) will restart with the default values.
  • During the QSA process, be careful to re-enter the correct passwords. If you made a mistake, you will end with the message below. Have a look at the QSims/web/qsmanager/settings/config.php file to check your entries. You can directly made the correct in this file if any.
Database error: Link_ID == false, connect failed
MySQL error: 0 ()
Session halted.


Cannot reach a Grid

You try to access a grid but it does not respond (eg. in Hippo clicking "Get Grids Info" returns Cannot retrieve grid info from server).
  • Check if Mono is running (in a SSH console type: mono -V)
  • Check if all servers are running - On QS-Manager, click Administration in the menu to display the server status
  • A server may be down, start again Q-Sims to fix this problem.
  • One or more servers may be zombie. Stop Q-Sims to fix this problem.
  • You have not forwarded the correct ports (see Installation)
  • Check if the server(s) is(are) running: Type http ://<your_ip>:server_port/simstatus/ where server_port=9000 in Standalone mode and in Grid mode (9000, 8001, 8002, 8003, 8004, 8006 and 9001-x according to the number of regions). if the server is running you will get a "OK" displayed or an Error 404 with the following page:

Ooops!

The page you requested has been obsconded with by knomes. Find hippos quick!

If you are trying to log-in, your link parameters should have: "-loginpage http :///?method=login -loginuri http :///" in your link


Cannot login with the Viewer

When you click on the Viewer connect button you get a message telling that you cannot be login.
  • Have you completed the installation process? With Q-Sims FULL Edition, the QS-Manager Home page shall be displayed - Do not forget to press the "Home" button
  • Check the grid can be reached (see above)
  • One database is not completely set up (eg. the Inventory DB for your avatar). Stop and Restart Q-Sims to complete the DB initialization.
Problem during first access with incomplete database
  • You may try to log to a region which is no longer available or the previous location is no longer available
Q-Sims selected region is not available
  • Clear you Viewer cache (Preferences/Web/Clear Now)
  • Retry (I have to do it sometimes 5-10 times in a raw while the server is clearing the previous aborted session and the viewer cache reloading!) You may have not been correctly reported as logging out the last time and OpenSim believes your are still logged.
Logging after a incomplete logout
  • Delete the Opensim cache directory (/share/xxx_DATA/.qpkg/QSims(_lite)/bin/add-db-xxx)
  • The account you are using is not confirmed. With the Q-Sims FULL Edition, in the QS-Manager admin page, under User management, check the status of the account you want to use.
  • Your Login URI is incorrect. You must use port 9000 (or the one set during installation if different from 9000) to access in Standalone and 8002 in grid mode. The login page shown in Hippo tells you the correct URI. In QS-Manager, check the Status box in the top right corner for the correct Login URI.
  • You may also select from the region box the region to access otherwise the Viewer will try to teleport you to you last position.
  • You have to retry, the Hippo viewer is sometimes reporting you as already logged. This is a cache/timeout issue.
  • Your MySQL database may be corrupted or incompatible (this can be the case after an upgrade)
  • If a message says "Regions is not found" and you are sure to have it, keep in mind the time needed for the simulator after a restart to reload all the regions and objects.


Scene rendering issues

You may have some issues while navigating the metavers. For example:
  • Prims are not correctly displayed (but it take time to load all textures)
  • Prims construction is slow on a powerful machine
  • Prims with light are not visible at night (light is visible when your avatar is closed or during prim edition)
=> IT IS MANDATORY TO UPDATE YOUR GRAPHIC CARD DRIVER TO THE LATEST VERSION.


It was working and now crashes - I'm tired of this application!

MY RECOMMENDATION: Leave it as it is for today, just relax and come back tomorrow.
I know what you feel and I always found the solution to make it work.
The development is still in alpha status and there is still some limitations.

RTENOTITLE Important Note: OpenSim uses a queuing system and YOU MUST KEEP THIS IN MIND. Requests are sent to the OpenSim simulator by the viewer for example and processed asynchronously in a FIFO order (first in-first out). A high amount of requests can crash the simulator. This is the reason why you have to be patient and wait for the requests to be processed.


I have notice crashes:

  • when upgrading to a newer version of OpenSim and not waiting for the OpenSim.exe to have processed all queue requests before lauching the viewer. The initialization can takes several minutes (10-15 according to your Sims complexity). The first time, you better start OpenSim.exe in a console to monitor the progresses and launch the Viewer when the queuing is completed (all scripts loaded and asset's storing finished).
  • with Sims with lot of prims and/or regions (eg 5 regions on a TS-639). Starting a fresh installation of a viewer (eg. a new visitor join the Sims on a new client machine or you have reinstalled your viewer) needs to fill in the cache and send a large amount of requests due to the number of regions and objects in the regions.

You may have to restart several times the viewer and the simulator (I went up to 15 restarts) while the cache is filling in.

To avoid crashes, you better:

  • upgrade to newer version ONLY if required (new mandatory feature or major bug fixes)
  • Limit the number of regions (or get a more powerful server). Read the Client Side section of Requirements on the Home page.
  • Do not expect too much despite the very good level of maturity of the OpenSim simulator.
  • Limit the number of prims (try to use as much as possible the prims parameters to build complex forms rather than linking several prims)
  • WAIT, WAIT, WAIT, WAIT ... and be patient - This may be the most difficult part of your Sims development. This is due to the asynchronous queuing implementation.


Video issues

After restoring the MySQL database, you may lost the video feature. The texture of your video prim for what reason is no longer the correct one (for example has been set to Blank Texture instead of Default Media Texture).
  • Right click the screen and select Edit..., on the Object tab check if the object is not locked, on the Texture tab click the texture thumb and select Default Media Texture, click the Color tab and set to white color, check Full bright.
  • Read also the Audio & Video section to check the parameters.


Voice chat issues

If you encounter some issues with the Voice Chat, please check:
  • The port 5060 is correctly forwarded.
  • You shall enable the Voice in your Viewers Preferences (on each client machine)
  • You must have enabled the Voice in each parcel.
  • Adjust the sound card parameters for microphone as well as the relative sound level on the Viewer (there are several cursors to adjust the different levels in the Viewer)
  • if you have re-install FreeSwitch or made a first Q-Sims installation without FreeSwitch and then added FreeSwitch, you miss the FreeSwitch modifications required for Q-Sims.
  • Stop both Q-Sims and FreeSwitch QPKG.
  • Goto the Web Interface (Click the link on the Q-Sims QPKG) and re-run the Q-Sims QSA (Installation) keeping the default values (previous settings). Press Apply to re-enter all the values. The FreeSwitch modification will be applied again.
  • Restart the FreeSwitch and Q-Sims QPKG; wait for the servers to be up and running.
  • or manually configure FreeSwitch
  • You must use the default FreeSwitch password (password) or you must modify the freeswitch configuration files accordingly.
  • DON'T RUSH each server needs time to get up and running. During debug you better have two different consoles to monitor the progression of each service and choose the Standalone mode. Go into the Q-Sims root directory, type cd bin, type mono OpenSim.exe. In the second console type ./freeswitch.sh start once Q-Sims is ready.
  • Stop all applications using port 5060 other than FreeSwitch such as Asterisk (I have been trapped by Asterisk running on port 5060 even it was disabled on the QNAP page but was started despite the disabling after a reboot)


User registration issues (Q-Sims FULL Edition)

If the user cannot send mail during registration:
  • Check the php.ini and update with your ISP mail parameters (below are the default values in the initial php.ini)
  [mail function]
  SMTP = localhost
  smtp_port = 25
  sendmail_path = /usr/sbin/sendmail -t -i
  • or overwrite the php.ini default value by adding these lines with your ISP mail parameters at the top of the /share/xxx_DATA/.qpkg/QSims/web/qsmanager/settings/config.php file:
  ini_set("SMTP","smtp.your_isp.com" );
  ini_set("smtp_port ",25);
  ini_set('sendmail_from', 'user@your_isp.com'); 
  • Reboot your Apache server with new parameters
# /etc/init.d/Qthttpd.sh restart

NOTE: PHP MAIL function looks a little bit erratic. I set some settings which did not worked but all of a sudden were working - no clear answer on the web regarding the topic "Cannot send mail outside domain" neither. So good luck.


Debugging your region/parcel

  • Cannot set the parcel property
  • you are not the parcel owner, connect with the owner account
  • you have issues with the UUIDs. Check the regions UUID in the bin/Regions directory the zzzzz.xml or zzzzz.ini files that correspond to the regions with troubles and the UUID of the owner. Analyze and correct the issue accordingly.


  • After some building, you may encounter some troubles with scripts and/or objects. Fortunately, there is some tools for debugging.
Click in the menu bar World and Region/Estate.... Select the Debug tab and you can have some information and actions for debugging.
Region/Estate debugging screen
Select Get To Colliders... or Get Top Scripts...to display the list of objects/scripts involved. Selecting one object from the list will display the beacon (red arrow) to help to locate the selected object.


Economy does not work

Economy is not yet functional in Q-Sims FULL Edition running Private grid.
Some Public grids have enable some monetary functions.

If the banker selection is not correct, you must reselect the Banker after a reinstallation.
The Banker selection will update the newly created configuration with your selection.


Avatar issues

The snapshot below shows the representation of an undefined avatar. Such situation occurs:
  • whenever a new avatar arrives into a region
  • when the inventory database that contents the avatars textures cannot be reached.
incomplete avatar represented as a ghost
  • With an incompletely loaded inventory, your avatar can appear grayed.
  • You shall "rebake" your avatar using the Advanced menu or press CTRL + ALT + R
  • Edit one parameters of the appearance to return to normal.
  • This may work for the current session/region only and needs to be redone.
incomplete avatar represented as a ghost


Issues with Mono

  • Check if the servers (OpenSim and UGAIM with Private grid) are running using the command: http ://<your_ip>:server_port/simstatus.
  • Shall problems occur, try to increase the number of threads.
export MONO_THREADS_PER_CPU=150


Issues with TwonkyMedia

  • if you have selected the default port 9000 for OpenSim connection and the uPnP MediaCenter (TwonkyMedia) is enabled on your NAS, the port 9000 is already used.
  • With the OSGrid.org Public grid you cannot change the default port 9000. Therefore you may need to change your MediaCenter default port (e.g. 9090)
  • You may also try to stop and restart the TwonkyMedia server because "TwonkyMedia server uses the TCP ports starting at 9000 until a free port is found". Keep in mind that each region uses a 900x port. Therefore with a Sims made of 3 regions, the ports 9000, 9001 and 9002 will be used.


Cannot teleport

  • Cannot log to osgrid.org:
  • see Issues with TwonkyMedia above
  • Check the real availability of your XY location on the grid.
  • if you have not selected the default port 9000 for OpenSim connection (eg. uPnP is enabled on your NAS and uses the port 9000 already)
  • you shall move your region (default.xml) to a Internet accessible directory
  • you must embrace the content into <Regions> tags.
<Regions>
	<Root>
	<Config sim_UUID=..... 
	... object_capacity="0" />
	</Root>
</Regions>
  • you need to update in the bin/OpenSim.ini the following parameters to provide the Region's file path:
;region_info_source = "filesystem"
region_info_source = "web"
regionload_webserver_url = "http://example.com/default.xml";
  • Check your server is running on your NAS
  • Does your Q-Sims appear in the regions box on the Hippo screen?
  • Have selected your region in the Hippo's Region box before connecting?
  • Voice chat no longer working:
  • After an OpenSim upgrade (overwrite of the bin folder with the new version), you may lost the FreeSwitch settings.
    Manually restore the Freeswitch configuration or if the OpenSim.ini was backuped (Q-Sims FULL Edition) use it.

LINKS

If you need to chat with others OpenSim and/or OSGrid.org users or administrators, connect your IRC at:


Websites and forums are available at: